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1 Introduction 

1.1 Overview 

This operational manual provides a general instruction of how to use a Software. The manual 

assumes that the user have a working knowledge of weaving, computer and its operating 

conventions, including how to use a mouse and standard menus and commands. 

1.2 Usage and Warning  

Digital India Corporation (formerly Media Lab Asia) is trying to enhance its product so that you 

can get the quality product. Therefore, it may happen that the user manual and program you are 

using are inconsistent. It means you will find some new features in the different version. We are 

trying to enhance the application and trying to make it as simple as we can. An online help is also 

being provided through bunai.medialabasia.in. We would like to get comments, feedbacks, and 

suggestions from our users along with the report on malfunctioning. We will try to incorporate all 

of you feedback /suggestions but sometimes we will not be able to implement all your suggestions.  

1.3 About software  

This tool is used to make all over figured as well as weave based pattern fabrics such as Saree, 

brocades, dress material, stole, scarf, suiting & shirting etc. The fabrics are woven on a loom 

having Jacquard (s) attachment to control individual warps.  Jacquard Design Fabrics are costly 

because of the time and skill involved in making the Jacquard cards, preparing the loom to produce 

a new pattern, and the slowness of the weaving operation. The Jacquard designs consist two or 

more basic weaves & different weaves used for the background. The software helps the user in 

design making & editing, assigning different weaves in the design and creating graph of the design. 

User can either take the printout of design or give the command to computerized jacquard card 

punching machine.  

1.4 Application Requirements 

1.4.1 Hardware Requirement 

The software will work with the following configuration smoothly: 

         Processor: Core i3 or above 

         RAM: Minimum 4 GB or above 



13 | P a g e  

 

         Graphics- 2GB 

1.4.2 Software Requirement 

The minimum Software requirement for running Open Source CAD Tool is: 

         Operating System: Windows 7, Windows 8, Windows 10. 

         Java Runtime Environment: 1.7 

         MySQL: 5.6 or above 

1.5 Program Installation 

1.5.1 User Registration 

The DigiBunai™ needs user registration before installation. User can register on DigiBunai website 

(https://digibunai.dic.gov.in/) & follow the steps to download the DigiBunai CATD installer. 

Open the Website & click on ‘Login’. 

 

 

 

 

  

User can fill their registration details. The acount activation link will be automatically send to 

user Email id after clicking on submit.  

https://digibunai.dic.gov.in/
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Check the DigiBunai™ account activation on Email & click on the verification link 
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Fill the Login Details & click on LOGIN 

 

Click on the Downloads
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Click on Installer to download the software 

 

Extract the installer from the zip file 
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Extracted file created a ‘DigiBunai Installer’ folder & click on the folder after completing 

extraction process 

 

 

Click on ‘DigiBunai.exe’ to start installation process  
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1.6 Installation of DigiBunai™  

 

 

 
 

 
  

 

 

 

 
 

  

    

Initializing Java installation 

 
Click on ‘Next’ for further 

processing 

click on ‘Next’ 
Click on ‘Next’ 
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Display of Java Installation completion, 

Click on ‘Close’ 

 

‘Accept the License Terms’ & click 

‘Next’ 

 

Choose the setup ‘Server Only’ & click 

on ‘Next’ 
 

Click on ‘Execute’ for further 

processing 
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Click on ‘Next’ 

 
Click on ‘Next’ 

 

Set the ‘MySQL Root Password’ 

& click on ‘Next’ 

 

Click on ‘Next’ 
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Click on ‘Next’ 

 

 

Click on ‘Execute’ to configure the 

program 

 

Configuration complete (by green colour 

√ indications) than click ‘Finish’ 
Click on ‘Next’ 
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Click on ‘Finish’ to close the MySql 

Installation window 

 

Click on ‘Next’ 

 

DigiBunai Application Installation starts, 

Click on ‘Next’ 

 

Click on ‘Install’ 
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Click on ‘Finish’ 

 

Click on ‘Next’ 

 

Put the password same as MySQl password then 

Click on ‘Test Connection’ 
 

Click on ‘DigiBunai’ Icon 
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See the message ‘Connection Successful’ then 

Click on ‘Next’ 

 

Click on ‘Next’ 

 

Click on ‘Finish’ 
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1.6.1 Create New User - Sign Up 

User need to fill the details and accept the Terms & Condition and click on the submit Button. 

 

  

 

1.6.2 Login the Existing Users – Sign In 

User need to enter the user name and password and click on Sign In Button. 

1.6.3 Forget Password 

         In case user forgot the password, he/she needs to click on the Forgot Password Button and 

the below screen will appear. 

         User needs to enter username and email and a new password will be sent to the registered 

email ID. 

 

Forget Password 

Fill the details for Registration & click on 

‘Submit’ 
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1.7 Running the Application 

Click on the DigiBunai Shortcut Icon 

 

 

 

  

 

 

  

 

1.8 Dashboard 

After the Login, a dashboard screen will appear as below: 

 

DigiBunai™ Dashboard 

The dashboard shows the recent work done by the user in the form of recent artwork, weaves and 

fabrics. There will be the name of the user on the screen i.e. Welcome ‘User Name’.  

 

Click on ‘DigiBunai’ Icon 
Fill Username & Password then click on 

‘Sign In’  
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1.8.1 Fabric and Artwork Size 

User need to enter the size of the different component of Saree viz. Border, Cross Border, Pallu 

(Anchal), Body (Pot), Konia and Skirt. Different parameters for fabric weaving required to fill in 

this section like Reed Count (Stockport), Thread per dent, Ends per inch, Picks per inch, Fabric 

length & Fabric Width. 

 

1.8.2 Warp thread 

User need to enter the yarn properties viz. type, color, count, twist etc. 

1.8.3 Weft thread 

User need to enter the yarn properties viz. type, color, count, twist etc. 

1.8.4 Miscellaneous 

User need to specify the, repeat, maximum float, binding, protection, color palette, & Maximum 

Artwork Color. 
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1.8.5 User Settings 

User need to set the language, resolution, Dots Per Inch, measurement system, currency, theme, 

font of the header and path for saving the different files viz. export, import, log etc. 
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1.8.6 User Preferences 

User need to specify the preferences to authenticate the data (work done) i.e. public, protected or 

private. Based on the authentication, data will be shared to other users.  

 

 

1.8.7 User Profile 

User can edit his/her profile by User Profile menu.  
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1.8.8 Information flow in the Application 
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1.8.9 Creating a Digital Fabric  

1.8.9.1 Dobby Weave 

Dobby module of DigiBunaiTM is the initiation of Weave designing. Before making any design in 

DigiBunaiTM CAD software, different types of weave prepare in this module. In this module, first 

of all, size of the weave design is determined by going into the 'File' menu, after that weave is 

filled with different colors of threads. The complete view of fabric is ready to visualize, we can 

see different views of the fabric by click on 'View' menu. 

       

 

File

Save/Save As <save the created weaves 
& fabric> 

Export  <export the weave> 
Export As HTML  <weave export with Peg plan, Draft, 

Treadling Sequence>
Print <print the weave pattern with 

fabric front side>

View <viewing the weaving patterns of the dobby fabric>

Rendering

Front Visualization /Rear 
Visualization <thread 

interlacement visualization of 
created fabric with weave>.

Grid View  
Tilled Vew <created weave by 

showing weave repeats> 

Colour Ways <fabrics with 
different colour combination of 

warp and weft yarn> 
Sample View Simulation

Edit <edit the weave & yarn>

Edit Fuctions like Insert/Delete/Mirror/ 
Tilt/Inversion/Rotation/Repeats Double Cloth Extra Warp Complex Weave Thread Sequence

Create <create the weave size> 

Warp Weft Shaft Treadle

File
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The Creation of Jacquard Designs:  

DigiBunaiTM has two modules to prepare jacquard designs. These are Artwork Designer & Fabric 

Creator. Both of the modules has functionality to crate graph & punching support for manual as 

well as automatic punching mode. It also produces the yarn split image for weaving by using 

Electronic Jacquard. User can visualize the fabric (which generate from the created design) from 

different angles (Front/Rear/Flip) in Fabric Creator.    

1.8.9.2 Artwork Designer 

AD works on Sketch to Graph mode. It use to convert the sketches in to workable artworks or 

designs. For this purpose first Import' the sketch (scanned image) by going into the File menu and 

click on 'Edit', to perform different functions like Resize the dimensions, Reduce colors, Design 

Editing, Weave Filling & Graph Corrections etc. Now we can see different views of designs after 

clicking on ‘View Menu’.  

     

 

 

File
Save/Save As <save the 

Designs/Artwork> 

Export As Texture 

<export the texture of 
design>

Export As Grid <export the 
design in grid form>. 

Export As Graph <export 
design in graphical form> 

Print <print the design> 
Export As Text <Numeric 

Graph>

Punch Application <Design card punching by using Electronic Card punching> 
Single Page-Single Graph

<punch the design for single color extra 
weft weaving >

Multi page- Multi graph 

<punching with multiple colors extra wefts> 

Superimposed Single Graph 

<multiple colors punching in a single 
command>

Superimposed Single Base Graph

<punch the base weave with multiple color 
design punching>

Utility 

View <Design visualize in different forms> 
Front Side <editable visualization of 

design>. 

Front Visualization <thread like visual 
effects in Front visualization of 

artwork/design> 

Front Cut <pick wise colours separation in 
front cut of artwork/design> 

Grid View /Graph View <Grid & 
Graph view of artwork/design>

IKAT Effect 

Edit <Convert the scan design into jacquard designs>
Resize Dimensions <change 
the height and width of an 

Artwork/Design>

Reduce Colour 
<reducing the colors 
in Design/Artwork >

Graph Corrections 
<corrections or editing in 

Design/Artwork on graph> 

Fill tool <fill colours in 
design> 

Jacquard Conversion <fill the 
weave in design> 

Repeat Orientation <repeats of 
artwork/design> 

Import File <sketch/Design import>

ARTWORK DESIGNER
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1.8.9.3 Fabric Creator 

FC works on Artwork to Fabric mode. Different types of weaves fills in Artwork on color bases 

and distortion of design boundaries during weave filling are secured  by click on ‘Don’t touched 

border of motif’. 

In this module, we can do various types of improvements and selections such as Weaving patterns, 

Graph corrections, Yarns color change, Yarn colors sequencing, etc. This module facilitates 

different views of created fabrics. By going into the 'utility' of this module, we can calculate the 

consumption of yarns as well as cost of production. 

 

 

 

File
Save/ Save As 
<Save Fabric>

Export As Texture 
<export the design 

texture of the fabric>  

Export As Grid <export 
the design in grid 

from>  

Export As Graph 
<export the design in 

the form of graph> 

Export As HTML 
<export the fabric with 
the complete technical 

details> 

Print <print the 
designs in different 

forms> 

Export As Text 
<Numeric Graph>

Utility
Consumption Calculation <actual yarn consumption for 

producing finished fabric>.  
Price Calculator <calculate the cost of fabric 

production>. 
Punch Application <design card punching by using 

Electronic Card punching>  

View <Visualization of Jacquard Designs on Fabric> 
Front Side /Rear Side <Front 
& Back view of the Fabric>.

Front Visualization/ Rear Visualization 
<visualization of the fabric shows yarns> 

Front Cut / Rear Cut <fabric 
with yarn colour separation>.  

Grid View/ Graph View    <see 
the Design in the grid & Graph 

Form>

Fabric 
Rendering

Simulation

Edit <Creation of Jacquard Fabrics & Editing> 
Transform Operation <edit 

the weaving pattern> 
Graph Correction <edit the 

design on graph> 
Yarn  Properties <editing the 

yarn properties>
Density <change the Ends per 

Inch and Picks per Inch >
Thread Sequence <change the pattern of 
thread sequence in the base of the fabric

Apply

Edit

Jacquard Conversion <select a weave for each 
colour of the artwork> Thread Sequence

Yarn 
Density

Repeats
Transform Operation <Modify design 

orientations> 

Create <Selection of Weave for base fabric>

File

Fabric Creator
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1.8.9.4 Garment Viewer 

This module is used to see different garment layouts & also facilitates different orientations of 

design on fabric. We can save & export of these layouts according to the requirement. 

        

 

 

 

 

File

Save/Save As <created garment 
layout save in the Library> 

Export As Texture <export the 
garment texture> 

Export As HTML <Export garment 
construction details>

Export As Graph <Export graphs of 
garment

Print <print the Garment Layout>

Assignments, Editing & Export

Fabric Assignment <assign the fabric in 
each and every section of the layout>

Edit Fabric (Yarn Properties, Thread Sequence, 
Density & Repeat Orientation) 

<provides the Design & Fabric parameters 
changing facility> 

Print Graph <print the graph of 
individual garment component>

Export As Graph 
<garment component 

can be individually 
exported> 

Export As HTML <garment 
component can be 

individually exported> 

Edit < Garment Layouts Creation > 

Pre Defined Layout/Custom Layout <select the predefined 
template of garment layout or customized it>

Repeats <repeats of individual garment components> Symmetry <symmetry between the garment components> 

Garment Viewer
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2 Fabric Creator Module 

2.1 New fabric creation (Selection of Weave for base fabric) 

You can create new fabric by clicking on   

Create icon in the File Menu. To create a 

fabric user need to select base weave first 

from the library. On clicking on Create icon 

in the File Menu, an image browser Window 

will pop showing the weave library for the 

base of the fabric 

User need to select at least one weave and 

this will reflect on the fabric as base weave. 

If required weave is not available in the 

library, user need to take the help of weave 

editor module to create the weave & also user can create weave during assignment in artwork. This 

weave can be changed or modified during the weave assignment to the artwork.  

After selecting the base weave, a base fabric will be reflected on the window.  

 

2.2 Creation of Jacquard Fabrics & Editing (Edit) 

To prepare the Jacquard designs for weaving, user can go to edit & perform different functions to 

develop Jacquard based digital fabric. The fabric & Design can be from different aspects like 

weave, pattern, yarn, density, thread sequencing, etc. 
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2.2.1 Jacquard Conversion 

To assign an artwork in the base fabric, user can either select Artwork Assignment icon in the Edit 

Menu or user need to right click on the fabric and Jacquard conversion option may be selected.  

User can Import the Artwork from external source or open from the CAD library by Import 

Browse. In the artwork assignment section, the artwork will be displayed in the different colours. 

Each colour of the artwork reflects a weaving pattern. User need to select a weave for each and 

every colour of the artwork. 
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2.2.1.1 Assigning Weaves in base and Artwork (design) 

When user will select the artwork, two rows of boxes will appear if the 0 Extra wefts are selected 

in the Weaving Mode. Number of boxes in the row will depend on the number of colors in the 

artwork. In the first row, all the boxes will be filled with the colors of the artwork. The second row 

(base weft yarn) of boxes is for the base weave of the fabric. By default base weave of the fabric 

will be assigned to the first box. User can assign the weaves in the other boxes by clicking on the 

box. This way is also use to assign weaves with extra wefts in design.   

 

 

 

Color Area for Weave Assignment 

Base Warp/Weft Weave Assignment 

1 Extra Warp/Weft Weave Assignment 

2 Extra Warp/Weft Weave Assignment 
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2.2.1.2 Assigning Extra Weft for Design 

In case of extra weft user needs to select no. of extra weft in the weaving mode. If user select 1 

extra weft, 1 row will be added, in case of 2 extra wefts, 2 rows will be added.  

2.2.1.3 Assigning Extra Warp for Design 

If user wants to create the design on fabric by using Extra Warp so it needs to be select Extra 

Warp in Jacquard Conversion window. Here weave assignment procedure is same as use for extra 

weft designing.  

2.2.1.3 Assigning less extra wefts than colours of Artwork 

If user wants lesser extra wefts than artwork colors then user can select the lower value of extra 

weft in weaving mode for example there are 4 colors in the artwork and user wants to use only 1 

extra weft in that case use needs to assign the base wave in the second row, weaves for extra weft 

in the third row of the boxes. 

2.2.1.4 Removing the weaveIn case user needs to <remove the weave> from the box, alt+ click on 

the box. 

2.2.1.5 Fabric Type 

In the fabric type, user can select type of the fabric in the form of kadhua, fekuwa-with float, 

fekuwa-with cutwork, tanchoi, float binding-regular, float binding-irregular. Based on the 

selection, backside view of the fabric will be changed. 

2.2.1.6 Weave of Original Size of Artwork 

The user has to option to fix the design size on fabric. First based on the fabric preferences, the 

size of the motif will be calculated; second based on the original size of the motif. User need to 

select option to keep the original size of the artwork. 

2.2.1.7 Don’t touch border of Motif  

This option is to keep the outline of the artwork smooth. User need to select the option of don’t 

touch the border of Motif.  

2.2.2 Transform Operation 

User can edit the weaving pattern as and when needed, all the changes in the weaving pattern will 

be reflected in the graph as well as Fabric.   
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2.2.3 Graph Correction 

User can edit the design on graph manually to give the finishing touch for the artwork. There will 

be the boxes for warp, weft and extra wefts which user need to select the box (color selection) 

wherever changes are required.   
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Graph Corrections 

 

2.2.3.1 Float finding & Binding 

If user wants to find the maximum float size in the fabric then user need to enter the maximum 

float value in the text box and select the box Show Floating Error on Graph. 

User has two options for float binding, one is manually where user can edit the floats manually 

and second one is automatically where user needs to select the box of Bind Float on Graph by 

assigning the maximum float value. 

 

           

                     Float Finding                                                           Float Binding 

 

 

2.2.4 Yarn Properties 

For editing the yarn properties, user need to select the option of Yarn Properties.  User can change 

the colour of Warp, Weft or Extra weft yarns. The effect of other parameters like, thread count, 

ply, diameter factor, twist (count & sense), and hairiness will reflects in Fabric Simulation (Further 

releases). 
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2.2.5 Density 

In the density user can change the Ends per Inch and Picks per Inch of the fabric. 

  

2.2.6 Thread Sequence 

Use can change the pattern of thread sequence in the base of the fabric. The new thread sequence 

can be saved and used further as and when required.  
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2.2.7 Switching Colours  

Switch color option interchange the color of warp and weft yarns. Use need to click on Edit -> 

Switch Color Option. 

       

  

 

2.2.8 Repeat Orientation  
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To visualize the Design repeats, 

click on Repeat Orientation & 

define the repeats (Vertical & 

Horizontal) of the design to 

visualize after check the Multiple 

Repeat.  

 

2.3 Visualization of Jacquard Designs on Fabric (View) 

It offers to visualize the fabric from various aspects like Front side look for fabric aesthetics, 

manner of yarn interlacements for fabric texture & strength, Back side for Yarn float visualization 

for durability aspects, Front cut for the order of arrangement of different yarn colors in fabric, 

Graph view for design dimension & aesthetic aspects, etc.  

 

 
 

 

 

2.3.1 Front/Rear Side View 
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This view shows the threads of warp, weft and extra weft in single pixel. The base and artwork (on 

the base) are represented as solid. It provides the Front & Back view of the Fabric. 

              

  

 2.3.2 Grid & Graph View 

This view is to see the Design in the grid & Graph Form. Grid does not influence by the loom 

parameters i.e. Reed, Density, Chauk size, etc. 

The graph view of the artwork depict all the weaves used in artwork along with the size of graph. 

The size of the graph is represented in the form of chauks. Suppose a design is created in 200 hook, 

it means 50 chauks. In Varanasi, the graph is calculated based on EPI and PPI.    

 

Rear Side Front Side 

Grid View 
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2.3.3 Front & Rear Visualization 

The front visualization of the fabric shows yarns in 3 pixels with the shading effect. This view 

gives a fabric look to the design. User can see all the yarns separately.   

Flip view shows the backside view of the fabric. This view shows the interlacement of the threads 

in the back side of the fabric.  

               

 

 

 

 

Front Visualization Rear Visualization 

Graph View 
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2.3.4   Front & Rear Cut  

Front cut is use to see front side of the <fabric with yarn colour separation>.  Rear cut is use to 

see back side of the fabric with yarn splitting. This view is also the representation of floating length 

of weft yarns. 

  

          

 

2.3.5 Simulation  

The application has one, very basic model of simulation where artworks are superimposed on the 

scanned images of the base fabric. The images of the base fabric with the different parameters are 

saved in to library. User can chose the type of base fabric and set the other parameters of simulation 

i.e. brightness, contrast, hue, saturation, etc. 

  

Front Cut Rear Cut 
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2.4 Save Fabric Creations & Outputs (File) 

2.4.1 Save Fabric 

After creating, editing the 

fabric there is the provision of 

saving the fabric into 

database. 

 

2.4.1.1 Public 

Public option to save the fabric which will be synchronized with central server and available for 

use to other users. 

2.4.1.2 Protected 

In the protected option to save, the fabric which will be synchronized with central server but other 

user will not be able see.    

2.4.1.3 Private 

In the private option to save, the fabric which will not be synchronized with central server. The 

work done by the user will be kept at local machine only    

2.4.2 Save As 

There is Save As option where user can provide different name of the fabric and authentication as 

per need.  

2.4.3 Printing 

The print module offers to print the designs in different forms with customized printing facility. 
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2.4.3.1 Print Grid 

Print grid option prints the design in the form of grid.  

2.4.3.2 Print Graph 

Print graph option is use to print the design in the form of graph after assigning weaves. This will 

be a one page graph. 

2.4.3.3 Print Fabric Visualization 

In case user wants to share the digital copy of the fabric. This option helps to take the print of 

texture (Fabric views & visualizations) of the fabric in the form of one repeat. 

Print

Front Side

Rear Side

Front 
Visualization

Rear 
Visualization

Front Cut

Rear Cut

Grid View

Graph View
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2.4.3.4 Print Front & Back View of Fabric 

It provides facility to print a unit repeat of created design with background fabric. 

2.4.3.5 Print Front & Rear Cut of Fabric 

It Provides facility to print a unit repeat of created design with background fabric in actual ordering 

view of different colors of yarns. 

2.4.4 Exports 

User can export various forms of Creation with construction parameters. 

 

2.4.4.1 Export as Grid 

It offers to export the design in grid from without background weave. 

2.4.4.2 Export as Graph 

User can export the design in the form of graph after assigning weaves. This will be image file 

.bmp on one single page.  

 

Grid

Graph

Texture

HTML
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2.4.4.3 Export as Texture 

Using this option, user can export the design texture of the fabric (Front side view image file .png) 

in one repeat.  

2.4.4.4 Export as HTML 

User can export the fabric with the complete technical details including size, EPI/PPI, warp, weft 

and extra weft details as follows: 
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2.4.4.5 Export as Text 

DigiBunai™ application has provision to export graph of the design in text format known as 

numeric graph. This representation uses numbers to denote points on graph for punch application. 

Further, there are two modes viz. ‘Numeric Graph Color’ and ‘Numeric Graph Background’ 

available 

 

2.5 Design Punching & Calculations 

After completing the design part, user need to punch the cards to start the weaving. There are three 

options for punching the punch cards 

2.5.1 Manual or Piano Card Punching 

In the manual punching process, user needs a printed graph, punch and punching plate. The 

punching plate decide the size of the card which match the punch plate of the cylinder mounted on 

jacquard. User manually reads the graph and punch the hole on the card. This process is very time 

consuming. 

Piano is the mechanical machine to punch the cards. In the piano punching also user needs a printed 

graph. User manually reads the graph and punch the hole on the card. This process is little bit faster 

than manual punching. 

In the both way of punching can be done by application generated printed graphs (File).  

2.5.2 Automatic Card Punching (Utility) 

The design card punching by using Electronic Card punching machine is much lesser time 

consume for punching. It also produce efficient outputs than manual methods (due to human 

errors). Users do not need to carry the printed graph, a soft copy of the design is required to give 

the command to punching machine. This application supports any punching machine. To give the 

punching command user need to go to Fabric Creator/Artwork Creator Module -> Utility Menu -

> Punch Application and then select the following options as per requirement. 
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2.5.2.1 Select Punch 

Type 

Usually punching machine 

takes the input of the design in 

two colors only. So we need to 

convert the multi colored 

design on two colors only and 

these two colors are counted as 

black and white. 

  

 

 Single Page-Single Graph 

If user wants the complete (with all the colors) in 

one page then he/she needs to select this option. 

This option use to punch the design for single color 

extra weft weaving.  
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 Multi Page-Single Graph 

 

 

  

 Multi Page-Multi Graph 

The punching image generated from this option use for punching with multiple colors extra wefts 
(as colors in design). All the colors in design will be separately punch & different punch cards 

sequentially arrange after punching. 
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 Superimposed-Single Graph 

If the design has more than two colors and 

user wants to give the punching in single 

command then super imposed single graph is 

the option where both the colors of the design 

merged together. There is no need to give 

color wise punching of the cards separately. 

This mode provides multiple colors punching 

in a single command. 

 

 

 

 Superimposed-Single base Graph 

If the design has more than two colors and 

user wants to give the punching in single 

command then super imposed single graph is 

the option where both the colors of the design 

merged together. It also provides facility to 

punch the base weave with multiple color 

design punching. 
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2.5.2.2 Select Punching Machine  

User need to select the Punching machine application i.e. driver of the punching machine 

connected with the computer. This option can directly transfer the design from application to 

punching machine.  

2.5.2.3 Service Password 

User need to enter the service password to give the command of punching from the security and 

authentication aspect. 

2.5.3 Consumption Calculation 

User can calculate the actual yarn consumption for producing finished fabric. 

2.5.4 Price Calculator 

It provides facility to calculate the cost of fabric production.  

 

2.6 Library of Fabrics (File) 

 User can open an existing fabric from the library through File -> Open 

When user will click on the Open, an image 

browser window will pop up which shows 

the fabrics in library. It also provides 

searching and sorting options based on the 

following parameters viz. Name, Date, 

Type. User can open the saved fabric by 

selecting fabric from library. 
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Load Recent option provides to open the recent created saved file on window after closing & 

reopen the module.   

2.6.1 Search 

User can search the fabric by name. User need to enter the starting character of name of the fabric, 

the list of fabrics will automatically be displayed. 

2.6.2 Sort  

 Sort by Date 

User has the option to sort the fabric by date (ascending order) 

 Sort by Name 

User can sort the fabric by Name  (ascending order alphabetically) 

 

3 Garment Layout  

Garment Viewer module is the play area for designer where they can see the design in the form of 

complete garment layout. User can try different combinations of designs, colors & design editing 

functions. In Edit menu user can select the predefined template of garment layout or customized 

it as per requirements.    

 



59 | P a g e  

 

3.1 Fabric Assignment  

In this section user need to assign the fabric in each and every section of the layout. By right click 

of the specific section, user can select the fabric from the library. If user clicked on the body, an 

image browser will be opened with the library of designs where user can chose the design for 

garment section. 

 

Fabric Assignments 

 

3.2 Edit Fabric 

This mode is provide to do changes or edit in assigned Fabric in Layout. The editing option 

provides the various design & Fabric parameters changing facility to visualize the garment in 

different ways.   
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3.2.1 Jacquard Conversion 

This function is useful to modify the weaves & extra wefts in design. After modification user can 

save it & changes will be reflect on Garment Layout. 
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3.2.2 Yarn Properties  

This feature gives the flexibility to the user for changing the warp, weft and extra weft yarn 

properties (currently colour of the yarn) on layout. Later on count of the yarn, ply, twisting, 

hairiness factor will be editable.   

 3.2.3 Thread Sequence 

This function provides the flexibility to users for various yarn color pattern generation on base 

fabric & visualize that effect on garment layout. 

3.2.4 Density 

Density parameters reflect the yarn density effect on layout with corresponding dimensions of the 

design. 

3.2.5 Repeat Orientation  

With this feature, user can change the repeat pattern of the design on layout i.e. ½ drop, 1/3 drop 

etc. User can rotate the artwork on layout by selecting the angle.   

3.2.6 Clear  

Clear function is to clear the fabric from the layout. 

 

3.3 Garment Layouts Creation (Edit) 

3.3.1 Saree 

In Varanasi, Saree has the different layouts in the form of various components of the Saree i.e. 

border, cross border, pallu, body.  

3.3.1.1 Pre-Defined Layout 

 Border across Body and Pallu 

In this layout, border goes across the cross border. The cross border limits up to the border only. 
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 Single Cross Border 

               Some of the Sarees have only one side cross border, body part start just after pallu.   
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 Border with Skirt border 

 

In this layout, a skirt is extra component along with border, cross border, pallu and body part of 

Saree. 

 

 Saree with Blouse 

This layout of the Saree is with Border Cross Border, Pally, Body and blouse piece. 
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User can also prepare the layout of different garments like Dress Material, Dupatta, Stole, Shawl, 

etc. 

3.3.1.2 Custom layout  

User can customize the components of 

garments by Custom Layout. 

 

 

 

 

 

 

 

 

 

3.3.1.3 Repeat & Symmetry Setting  

User can select the repeats of individual garment components by Repeats option. The symmetry 

between the garment components can be set by symmetry.    
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3.4 Secure Garment Layout & Outputs (File) 

This can provide the functionality to secure the created Layout in Library of Garment Viewer 

module. User can Export or Print the layout with supporting construction files. 
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 3.4.1 Print 

User can print the Garment Layout by clicking on Print. It also provides the facility to print the 

graph of individual garment component. For this purpose take the mouse pointer on design & right 

click. The option displayed on the screen ‘Print Graph’. 

3.4.2 Export 

User can export the garment texture by Export As texture, Export garment construction details 

by clicking on Export As HTML & Export graphs of garment by Export As Graph on the top 

menu bar of Garment Viewer. The garment component can be individually exported by right 

clicking on individual sections of Layout.  

3.4.3 Save  

The created garment layout save in the Library of Garment viewer by Save/Save As. 

 

3.4.4 Open 

The saved Garments Layouts can be seen in Library by clicking on ‘Open’. 

 

4 Dobby Weave 

Dobby Weave help users to create different weaves which will be used during the weave 

assignment to the artwork.  

4.1 Create Weave 

To create one repeat of the weave, user need to enter number of warp, weft, shaft and treadles. 

After assigning the above parameters, 4 grid will be appeared to the user i.e. design grid, drafting 

grid, ti-up grid and peg plan grid.  There are two options to create the weave size (other is by 

scrolling) and select warp colour and weft colour form colour palette.  
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4.1.1 Design to Drafting 

User need to create the weave by filling the design grid. Rest of the three grids will be calculated 

automatically. 

4.1.2 Drafting to Design 

If user knows the drafting the design then he/she needs to fill the drafting, ti-up and peg plan grid, 

design will automatically reflect in the design grid.  

 

4.2 Edit 

To edit the weave pattern, user can do the following operations. 
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4.2.1 Insert Warp 

There is provision to insert warp in the existing weaving pattern. The new warp will be inserted at 

the right side of the selected warp. 

4.2.2 Delete Warp 

To delete a warp, user need to select the warp first and then click on the delete warp option. 

4.2.3 Insert Weft 

There is the provision to insert a weft in the existing weaving pattern. The new weft will be inserted 

below the selected weft. 

4.2.4 Delete Weft 

To delete a weft, user need to select the weft first and then click on the delete weft option.  
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4.2.5 Select 

To select the area in the weave design, user need to click on the select option and drag to select 

the portion. The selected area will be represented in red colour.      

4.2.6 Copy 

User can copy selected area of the weave which can be used on any place in the weave area.  

4.2.7 Paste 

User can paste the copied area of weave on anywhere in the weave. The paste will start from the 

selected point. 

4.2.8 Mirroring  

User can Mirror the weave pattern (either vertically or horizontally).  

 Horizontal Mirror 

For mirroring the specific weave portion horizontally user will have to click on the Mirror 

Horizontal icon in the Edit menu bar. 

 Vertical Mirror 

For mirroring the mirroring the specific weave portion vertically user will have to click on the 

Mirror Vertical icon in the Edit menu bar. 

4.2.9   Clear 

User can clear the weave window by clicking on the clear option. After clicking on the clear, all 

the windows i.e. drafting, peg plan, ti-up and design window will be blank (except one point in 

design window).  

4.2.10 Move 

User can move weave pattern one unit or 8 unit in Left, Right, Up and down. 

 One Move by 1 

User click move one unit Move left, move Right, Move Up, Move Down. Weave pattern move 

by one unit in desire direction. 
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 Move by 8 

User click move eight unit Move left, move Right, Move Up, and Move Down. Weave pattern 

move by 8 unit in desire direction. 

 4.2.11 Tilt  

The tilt tool shifts every next line (or column) of the weave for one thread to the   desired direction. 

The most common use is for fast creation of satin weaves. This function is use to tilt the weave in 

different directions. 

 Right  

   Tilt right the weave (transforms vertical line to right diagonal). 

 Left 

 Tilt left the weave (transforms vertical line to left diagonal). 

 Up 

Tilt up the weave (transforms vertical line to up diagonal). 

 Down 

Tilt down the weave (transforms vertical line to down diagonal). 

4.2.12 Rotation 

 Clock Wise Rotation   

User can rotate whole weave pattern in clock wise direction. 

 Anti-Clockwise Rotation 

User can rotate whole weave pattern in anti-clock wise direction. 

4.2.13 Inversion 

For inverting the weave pattern user will have to click on the inversion icon in the Operation menu. 

It can reverse the yarn interlacements in weave. 

4.2.14 Double Layer Fabric 

Double layer Fabric has two sets of warps and two sets of wefts are interconnected to make a two-

layered fabric structure. Actually, this kind of structures contains two layers of yarns those are 

woven one above the other and stitched together. Double cloths have at least two series of warp 

yarns, and two series of weft yarns, namely face and back. 
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The upper layer is formed by interlacing the face warp yarns with the face weft yarns, and the 

lower layer is formed by interlacing the back warp yarns with the back weft yarns. The two layers 

may be only loosely connected together in which case, each may be readily identified as a different 

entity or they may be so intricately stitched or tied together that they appear to form a complex 

single structure. 

To create the two layer fabric structure user needs to initialize the parameters of composite weave 

(Warp, Weft, Healds, etc.). After defining the parameters user need to assign the thread color 

sequences for warp and weft yarns.  

 

Define two separate fabric layers for the combined weave structure 

 

 

 

 

 

 

 

 

   
Define Weave Parameters Assign Yarn Color Sequence 
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Create Weaves for two separate fabric layers & mark the mutual points between Warp Face thread 

& Back Weft Threads. Combined weave structure will automatically reflects on the main window. 

Mark the stitching points between Back Warp & Face Weft. 

 

 

 

The final fabric generated which is based on the input information on main weave window.  

 

 
Fabric Front Fabric Front Thread Visualization 
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4.2.15 Multi & Complex Weave  

Weave is the interlacement order of the warp & weft threads in fabric structure. It provides 

functional as well as aesthetics appeal in fabric. User create several weave patterns with multiple 

yarn color combinations to produce various fabrics. According to frequently change in market 

trend, user/buyer’s demands new or innovative weave patterns on fabrics. To suffice the market 

needs in order to frequent demand changes, designers thinking about to create new or innovative 

weave patterns.  Based on the designers work with market demand, DigiBunai™ CATD will 

provide facility to generate multiple weave patterns from single one & merging the various weave 

pattern in single one.  

To generate various patterns from a single weave structure, user first create a weave on the creation 

window & right click on the Peg Plan.  

 

 

Fabric Back Fabric Back Thread Visualization 
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After clicking on Peg Plan user choose any one option to generate the newer weave pattern based 

on shuffling the Peg Plan. 

 

 

 

   

 

The application also provide a facility to generate the complex weave structures by combining the 

various weaves. User needs first to click on Complex Weave & define the Weaving Mode (Warp 

Faced/Weft Faced). After selecting the weaving mode user needs to add various weaves to 

generate a complex weave structure. 
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4.2.16 Extra Warp (Dobby Patterns) 

The Extra Warp weaving starts with a layer of Extra Warp inserted with ground warp threads. To 

produce the Extra warp designing in Dobby module, user initially click on Complex Weave & 

select weaving mode “Extra Warp”. 

 

 

 

Extra Warp Fabric 
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4.3 View 

The View Menu option of the Dobby Weave Window will provide certain operations for viewing 

the weaving patterns of the dobby fabric at different view mode. 

 

4.3.1 Zoom-In 

Zoom-In can be obtained by clicking on the icon under the View menu. Weave Zoom In increases 

the size of pixel which represents the thread on the screen this allows the user to see the weave 

with more precision and accuracy. 

4.3.2 Zoom-Out 

Zoom out Mode can be obtained by clicking on the icon under the View menu. . 

Weave Zoom Out decrease the size of pixel which represents the thread on the screen this allow 

user to inspect the detail of the large weave. 
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4.3.3 Normal 

Normal Mode can be obtained by clicking on the icon under the View menu. This facilitates the 

user to retain the weave zoom at normal level at its default setting. 

4.3.4 Tiled View 

User can see fabric view of weave in 

tilled view under View menu. User 

can assure about the created weave 

by showing weave repeats in Tilled 

View. 

 

 

 
 

  

4.3.5 Front & Rear side View 

 User can see Front & Rear side view of fabric with weave in view under View Menu. 

  

 

 

4.3.6 Front & Rear Visualization 

Front View Rear View 

Tilled View 
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 User can see the thread interlacement visualization of created fabric with weave. 

 

 

 

 

4.3.7 Simulation View 

Front Visualization 

Rear Visualization 
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   User can see simulation view of fabric in View Menu. 

 

 

 

4.3.8 Colour ways  

User can see fabrics with different colour combination of warp and weft yarn under view menu in 

dobby weave. 

 

 

4.3.9 Pattern Rendering 

Fabric Simulation 
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User always wants to visualize their digital creations (weave based patterns in Dobby) on the end 

products. The application provides facility to see these creations on predefined 2D objects.   

Area on which pattern needs to be rendered is identified on the 2D object model by segregating 

background from rest of object area. Once this area is identified, next is to generate fabric (with 

repeats) which can be accommodated to this area. Finally, the fabric is superimposed on the region. 
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4.3.9 Secure the Weave creations & Weave Library (File) 

 

The function provides the facility 

to save the created weaves & 

fabric in Dobby Weave Library. 

 

4.4.1 Save/Save AS  

For saving the existing weave with new name into the library user has to click on Save As icon in 

the File menu, this will save the weave with new name inside the library. 
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For saving an existing weave into database library with modification user will have to click on 

save icon under the File Menu. 

4.4.2 Open & Load Recent 

User can open an existing created saved weave weave from the library by clicking on Open icon 

in the File Menu. After clicking on Open icon a Window will pop up which shows the weave to 

the user. 

Open Weave window that provides different searching and sorting options for user to search the 

weave & Sorting allows to sort the weave file on the basis of factors such as :- 

 Name –This helps a user to sort the weaves by name bases. 

 Date – This option helps user to Sort the weaves by Date updated or last saved. 

For e.g., if user last saved the weave file yesterday then with this option he can directly open the 

file without searching for particular one in library. 

User can see previous saved weave in load recent menu bar. 

 

4.5 Import & Export  

Dobby Weave provides the facility to the user to Import the weave ‘wif’ file that contains all the 

weaving related information. By clicking on Import icon under the File Menu. After clicking on 

Import icon, a file open dialogue box will appear for selecting a specific WIF file.  

Dobby Weave provides the facility to the 

user to export the weave in ‘wif’   format. 

The constructed weave export with Peg 

plan, Draft, Treadling Sequence by 

clicking on ‘Export As HTML’. 

User can export the weaving information 

by clicking on Export icon in the File 

menu.   

  

 



83 | P a g e  

 

4.6 Print (File) 

User can print the weave pattern with 

fabric front side, by clicking on ‘Print’. 

 

4.7 Entering into Fabric creator  

In case user move dobby weave to fabric Creator the selected weave will be assigned to the base 

of the fabric. 

 

 

5 Artwork Designer 

The artwork editor helps users to create and edit the artwork. The basic functionality has been 

given in the artwork, for the advanced CAD features user need switch to the design editor. The 

basic feature are as follows:   
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5.1 Create size  

If user wants to create a new artwork, a design editor window will be opened by right clicking on 

‘Create’. A workable area will display on screen for design creation. 

5.2 Sketch/Design Import   

If user have a hard copy of sketch/Design than sketch/Design import in application after scanning. 

Artwork Designer provides the facility to the user to import the png and jpg file that contains all 

the image related information. By clicking on Import icon under the File Menu. After clicking on 

Import icon, a file open dialogue box will appear for selecting a specific png and jpg file format. 

Now this design can be ready to convert into workable design for weaving. 

5.3 Design Secure & Library 

5.3.1 Save/Save AS 

User can save the Designs/Artwork in to library through save & Save As option. 
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5.3.2 Open  

After clicking on Open icon in the File Menu a Window will pop up, which shows the saved 

designs in Artwork Designer module. Open design/artwork window provides different searching 

and sorting options for user to search the artwork Filtering on file name displays the artwork which 

matches the search filter. Sorting that allows to sort the artwork file on the basis of factors such as 

- 

 Name –this helps a user to sort artwork on the name basis. 

 Date – This option helps user to sort artwork on the basis of Date updated or last saved. 

For e.g., if user last saved the artwork file yesterday then with this option he can directly open the 

file without searching for particular one in library. 

5.3.3 Load Recent 

User can open the recent saved artwork/design in load recent in File menu.  

 

5.4 Paint Application 

Artwork Designer provides the facility to the user to edit design/artwork in paint software’s 

(integrated). 

 

5.5 Import Refresh 

User can edit design/artwork by Arahne paint or MS paint save and click import refresh icon on 

Artwork Designer. It is open edited design/artwork. After clicking Import Refresh, artwork open 

with all paint editing work in DigiBunai™. 

5.6 Edit  

The Edit menu provides the different function to convert the scan design into jacquard designs. 
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5.6.1 Resize  

User has the option to change the 

height and width of an 

Artwork/Design by entering the 

number in height and width text field 

according to his choice. For 

Applying changes to an image user 

will have to click and apply button. 

User can also change the EPI (ends 

per inch) & PPI (picks per inch) of 

the Artwork/Design after locking the 

size. 
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5.6.2 Reduce Colours 

After importing an image, total number of colors in the image are identified and for reducing the 

colors in Design/Artwork  user can enter the reduction number or drag one color over number of 

colors from which it wants to replace the design colors with that particular color. For Applying 

changes to an image user will have to click Apply Button. 

 

5.6.3 Convert to Grey Scale/ Black & White 

User can convert the Artwork/Design into grey scale format by check on Grey scale icon/ button. 

For Applying changes after check convert to grey scale icon. 

User can convert the Artwork/Design into black and white format by check on Convert to Black 

& White button. For Applying changes after check convert to grey scale icon. 

 

        
Grey Scale Black & White Scale 
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5.6.4 Undo & Redo 

User can undo the edit operation performed by user on the artwork designer to reach its previous 

stage. 

User can Redo the removed operation performed by user on the artwork editor to reach its previous 

stage.  

5.6.5 Colour Fill 

User can fill colours in design on close area or existing design color bases.  

For this purpose use by ‘Single Instance’ 

for close area base color filling in 

Artwork/Design or ‘Color All Instances’ is 

use for existing Artwork/Design color 

replacements. 

 

 

5.6.6 Artwork sketch 

User can convert artwork or color filled 

design in to boundary sketch by clicking 

on Artwork Sketch. 

 

 

 

5.6.7 Repeat orientation & Modes 

User can see the repeats of artwork/design by using of Repeat Orientation (number of vertical and 

horizontal). Here use can see the design with different repeat modes. 
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5.6.7.1 Horizontal Modes  

   
 

 

 

 

 

         

 

 

 

Rectangular Repeat  

½ Horizontal Repeat 1/3 Horizontal Repeat 

1/6 Horizontal Repeat 
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5.6.7.2 Vertical Mode 

               

 

 

 

 

 

 

 

 

 

 

5.6.8 Design Mirroring with Repeats 

User can Mirror the Artwork/Design either vertically or horizontally.  

 Horizontal Mirroring with Design Repeats 

For mirroring the specific artwork horizontally user will have to click on the Mirror Horizontal 

icon in the Edit menu bar. 

             
Design Mirroring Design Horizontal Mirroring 

1/2 Vertical Repeat 1/3 Vertical Repeat 

1/6 Vertical Repeat 
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 Vertical Mirroring with Design Repeats 

For mirroring the specific artwork vertically user will have to click on the Mirror Vertical icon in 

the Edit menu bar. 

        

 

 

   

 

Design Horizontal Mirroring with Vertical Repeats 

Design  Mirroring Design Vertical Mirroring 

Design Vertical Mirroring with Horizontal Repeats 
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5.6.9 Jacquard Conversion 

It use to fill different weave patterns in the solid colour filled design. User can fill the weave in 

design on existing colour or close area bases. Here ‘Colour All Instance’ is use for weave pattern 

fill on colour bases & ‘Colour Single Instance’ use for close area base weave filling in design. The 

protection of the design boundaries during weave filling can be done by width protection.   

 

 

 
 

5.6.10 Graph correction 

The corrections or editing in Design/Artwork on graph can be done in Graph Corrections. User 

can edit the design by existing colours in design. User can see floats after defining the ‘Float Size’ 

and bind floats automatically on graph. 
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5.7 Jacquard Design Visualization (View) 

The created jacquard design visualize in different forms in ‘View’ mode. These forms are helpful 

to finalize the design for weaving  
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5.7.1 Front Side 

It shows the editable visualization of design. User can see & edit the design in Front side through 

Edit. 

5.7.2 Front Visualization 

User can see thread like visual effects in 

Front visualization of artwork/design in 

view Menu. 

 

Front Visualization 
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5.7.3 Front Cut 

User can see pick wise colours separation in 

front cut of artwork/design in view Menu.    

 

 

 

5.7.4 Zoom Levels 

 Zoom-In   

Zoom-In of artwork/design can be obtained by clicking on the icon under the View menu. Zoom 

In increases the size of pixel which represents the thread on the screen this allows the user to see 

the design/artwork with more precision and accuracy. 

 Zoom-Out 

Zoom out of artwork/design can be obtained by clicking on the icon under the View menu. Zoom 

Out decrease the size of pixel which represents the thread on the screen this allow user to inspect 

the detail of the large design/artwork. 

 Normal 

Normal View of design/Artwork can be obtained by clicking on the icon under the View menu. 

This facilitates the user to retain back the zooming level at its default setting. 

5.7.5 Grid & Graph View  

User can see Grid & Graph view of artwork/design in view menu. 

 

 Front Cut 
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5.7.6 Tilled View 

 

 

 

 

5.7.7 IKAT Effect 

The term ‘Ikat’ is derived from the Malay-Indonesian word ‘mangikat’ that means to bind or 

knot. It is a yarn resist technique wherein the yarns are tie-dyed, and on weaving a pattern is 

created on the surface of the fabric. An Ikat textile can be identified from the typical hazy 

patterning on fabric due to the resist dyeing of the yarns prior to weaving. 

The application facilitates IKAT visuals by defining offsets values in Horizontal (Weft wise) & 

Vertical (Warp Wise) directions. The offsets values defines by the user to reflect the penetration 

of dye on the binding regions of yarns.  

Tilled View 

Grid View Graph View 
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Initially user creates the design on Graph level. 

 

 

If user doing the warp IKAT, then define the 

value of the offset in vertical direction. 

 
 

If user doing the Weft IKAT then it needs to 

define value of the offset in horizontal 

direction. 
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5.8 Export & Print 

Artwork Designer provides the facility to export the texture of design, export design in graphical 

form & also export the design in grid form. User can also print the design forms after open it on 

the screen. Here different customization option available for printing. 

Assign the weave pattern to generate fabric in 

Fabric Creator & see the fabric after apply the 

settings.  

 

IKAT Fabric 
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6 Configuration (Utility) 

User can set fabric construction parameters before creating fabric. User can set thread name, thread 

color, thread count, thread count unit, thread diameter factor, thread twist, twist scene, hairiness, 

thread ply, crimp, thread pattern and loom waste in warp thread. 

 

 

 

6.1 Fabric/Artwork  

The user need to specify the Jacquard Design Dimensions, Fabric Dimensions, Construction 

Parameters (Yarn Count, Denting Order, Yarn Density), loom details in this mode. 
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6.2 Warp Thread 

This mode is use to set the parameters of warp yarn in software. These information take part to 

generate the fabric simulation, warp yarn consumption calculation & cost estimation of the final 

product. 

 



101 | P a g e  

 

6.2.1 Thread Name 

The name of the thread need to be specified by the user i.e. Silk, Cotton etc. 

6.2.2 Thread Colour 

User need to specify the colour of the yarn initially. 

6.2.3 Thread Count 

The yarn count depends on the width of the yarn. The count of yarn expresses the weight per units 

in unit length or vice-versa.  

6.2.4 Thread Count Unit 

The unit thread count i.e. denier, Tex etc. 

6.2.5 Thread Diameter Factor 

Diameter factor depends on the types of yarn. 

6.2.6 Thread Twist 

Shows the twists per meter 

6.2.7 Twist Sense 

This define the twist sense i.e. S, Z, or 0(no twist). 

6.2.8 Thread Hairiness  

Shows the hairiness property of the yarn.  

6.2.9 Thread Ply 

Define the yarn ply in a thread. 

6.2.10 Thread Price (Per gram) 

The user need to enter the price of the yarn 

6.2.11 Crimp  

The crimp varies upon the type of yarn. 
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6.3 Weft Thread 

This mode is use to <set the parameters of weft yarn> in software. These information take part to 

generate the fabric simulation, weft yarn consumption calculation & cost estimation of the final 

product. 

 

 

6.3.1 Thread Name 

The name of the thread need to be specified by the user i.e. Silk, Cotton etc. 

6.3.2 Thread Colour 

User need to specify the colour of the yarn initially. 

6.3.3 Thread Count 

The yarn count depends on the width of the yarn. The count of yarn expresses the number of weight 

per units in unit length or vice-versa. 

6.3.4 Thread Count Unit 

The unit thread count i.e. denier, Tex etc. 
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6.3.5 Thread Diameter Factor 

Diameter factor depends on the types of yarn. 

6.3.6 Thread Twist 

Shows the twists per meter. 

6.3.7 Twist Sense 

This define the twist sense i.e. S, Z, or 0(no twist). 

6.3.8 Thread Hairiness  

Shows the hairiness property of the yarn.  

6.3.9 Thread Ply 

Define the no. ply in a thread 

6.3.10 Thread Price (Per gram) 

The user need to enter the price of the yarn. 

6.3.11 Crimp  

The crimp varies upon the type of yarn. 

 

6.4 Miscellaneous Other Settings    

User can set multiple print, multiple repeat and punch card for machine. User can also set 

protection, binding, float size, floating error, vertical repeat and horizontal repeat, colour palette 

(pantone colour and web colour), designing charges, punching charges, properties charges, wages 

charges, overhead charges, percentage change profit and max colour use in artwork. 
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7 Support Modes 

User can convert yarn count, linear measure, weight in different unit. 

7.1 Conversion 

7.1.1 Yarn Count 

User can convert yarn count one unit to other unit. 

7.1.2 Linear Measure 

User can convert length one unit to other unit in linear conversion. 

7.1.3 Weight 

User can convert weight one unit to other unit in weight conversion. 

7.1.4 GSM Conversion 

User can calculate the GSM of fabric. 
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7.2 Application Integration 

User can add other application in DigiBunai™ by setting name, application type and application 

path in utility. 

 

 

  

7.2.1 Application Name 

User need to give a name to the application which will be added. 

7.2.2 Application Type 

The type of application need to be defined. 

7.2.3 Application path 

The storage path of the integrated application is shown on the window. 

 

 



106 | P a g e  

 

7.3 Simulator 

Every user wants to visualize the created digital design on actual fabric. For this purpose 

DigiBunai™ facilitates to add multiple fabric textures to simulate the digital design on fabrics.  

 

 

 

7.4 Import/Export 

The path of the exported file need to be specified by the user & import file need to be place at the 

specific location. User can export all the data (Weaves, Fabrics, and Garments) from the 

application. These files can be used in application on other computer system by Import. 

 

7.4.1 Data Export 
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This feature provides the facility to the 

user for exporting the fabric including 

the supported files of artwork and 

weaves. From the Security and 

confidentiality aspect, user also has the 

flexibility to wipe his complete data 

from the system after exporting to the 

external drive. For export, user need to 

select Utility Module –Export/Import - 

Export and user need to choose the 

following options 

 

 

 7.4.1.1 Fabric Data 

This option provides facility to export all the fabrics of the user to its external drive. 

7.4.1.2 Artwork Data 

This option is use to export all the artworks of user. 

7.4.1.3 Weave Data 

This option is use to export all the weaves of user. 

7.4.1.4 Export 

Export option will export the data to external drive and keep a copy into the database as well. 

7.4.1.5 Export & Delete 

This option will export the data to external drive and delete user’s data from the database. This 

feature is for those users who want to take out their complete data from the system.  

7.4.2 Data Import 
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This feature is for importing the data 
which was exported by the user. User 

can carry his/her data on the external 

drive and import as and when required.   

 

 

  

From the Security and confidentiality reason, some of the user do not want to leave their data on 

the system. They can export the complete data and import as per requirement.  

For import, user need to select Utility Module -> Export/Import-> Import -> browse the back of 

the exported data. 

 

7.5 Library 

User can see library of creations artwork, weave, fabric, color and cloth. User can export, delete, 

update and change permission artwork, weave, fabric, color and cloth. 

 

 

 

  

   

Weave Library Artwork Library Fabric Library 

Garment Library Color Library Yarn Library 



109 | P a g e  

 

 

7.5.1 Sorting 

User can sorting name or date wise in library. 

7.5.2 Searching  

User can search by name or product type in library. The user can search the weaves, designs and 

fabrics. 

7.5.3 Update 

User can update artwork, weave, color and fabric in library. 

7.5.4 Change Permission 

User can changes permission public, private and protected of artwork, weave, fabric and color in 

library. 

7.5.5 Export 

User can export library of weaves, design and fabric. 

7.5.6 Delete 

User can delete artwork, weave, fabric and cloth from library. 

7.5.7 Export & Delete 

User can export and delete artwork library, weave library, fabric and cloth library. 

 

 

7.6 Translator 

User can translate software functions names from English to Hindi. 
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7.6.1 Create 

The user can create his own localized Language library. 

7.6.2 Open 

The user can open Language library. 

7.6.3 Save 

The user can save his/her own language Library. 

7.6.4 Save As 

The user can open the existing language library, edit it & Save As in his/her name. 

 

7.7 Help 

This section define the software introduction, concern trainings, required system configurations & 

manufacturer. 

7.7.1 Help Guide 

        It shows user manual/guide of application to know about functionality of the software. 
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7.7.2 Video Guide 

        It shows the training videos of the software. 

7.7.3 Support 

7.7.3.1 Technical Information 

Technical specification for this software follows: 

             Operating System: Windows & Linux  

             RAM:                         4GB  

             Processor:                Core i5 

            Graphics Card:          4 GB dedicated  

             Java:                         Java 7  

             Flash Player:           Flash Player  

             Database Engine:   MySQL 5.x 

7.7.3.2 About Software 

DigiBunai™ aid's the weavers to create digital artwork and translate the saree design to be loaded 

to the looms. DigiBunai™ is a first of its kind Open Source software for Jacquard and dobby 

weaving. DigiBunai™ is customized for Banarasi Saree having the unique feature of Garment 

Viewer which works as a play area for designers/weavers. The software is customizable (local 

language and library of local designs) and also has the ability to integrate digital design tool of the 

user’s choice. 

7.7.3.3 Contact Us 

Digital India Corporation (Formerly Media Lab Asia)  

(Section 25 Company under the Ministry of Electronics and IT (MeitY), GoI) 

 

 
     

 

 

Mumbai (Corporate) 

Address: Samruddhi Venture Park, Central MIDC Road #2, 4th Floor, Andheri (East), Mumbai, 

Maharashtra, 400093 
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Phone: +91-22-2831-2930/ 31 

Fax: +91-22-2837-9158 

Website: https://dic.gov.in/ 

 

 New Delhi Office 

Address: 6 CGO Complex, Lodhi Road, New Delhi -110003 (India) 

Phone: +91-11-24360199 / 2431756 

 

7.7.3.4 Product Support 

Phone: +91-11-26443266 (CAD support team) 

Email: satyavir@digitalindia.gov.in / ashish@digitalindia.gov.in 

Web Portal: https://digibunai.dic.gov.in/ 

 

7.7.3.5 Sign Out 

You need to click on Sign Out Button to close the application 

https://dic.gov.in/
mailto:satyavir@digitalindia.gov.in
mailto:satyavir@digitalindia.gov.in
https://digibunai.dic.gov.in/

	1 Introduction
	1.1 Overview
	1.2 Usage and Warning
	1.3 About software
	1.4 Application Requirements
	1.4.1 Hardware Requirement
	1.4.2 Software Requirement

	1.5 Program Installation
	1.5.1 User Registration

	1.6 Installation of DigiBunai™
	1.6.1 Create New User - Sign Up
	1.6.2 Login the Existing Users – Sign In
	1.6.3 Forget Password

	1.7 Running the Application
	1.8 Dashboard
	1.8.1 Fabric and Artwork Size
	1.8.2 Warp thread
	1.8.3 Weft thread
	1.8.4 Miscellaneous
	1.8.5 User Settings
	1.8.6 User Preferences
	1.8.7 User Profile
	1.8.8 Information flow in the Application
	1.8.9 Creating a Digital Fabric
	1.8.9.1 Dobby Weave
	1.8.9.2 Artwork Designer
	1.8.9.3 Fabric Creator
	1.8.9.4 Garment Viewer


	2 Fabric Creator Module
	2.1 New fabric creation (Selection of Weave for base fabric)
	2.2 Creation of Jacquard Fabrics & Editing (Edit)
	2.2.1 Jacquard Conversion
	2.2.1.1 Assigning Weaves in base and Artwork (design)
	2.2.1.2 Assigning Extra Weft for Design
	2.2.1.3 Assigning Extra Warp for Design
	2.2.1.3 Assigning less extra wefts than colours of Artwork
	2.2.1.5 Fabric Type
	2.2.1.6 Weave of Original Size of Artwork
	2.2.1.7 Don’t touch border of Motif
	2.2.2 Transform Operation
	2.2.3 Graph Correction
	2.2.3.1 Float finding & Binding
	2.2.4 Yarn Properties
	2.2.5 Density
	2.2.6 Thread Sequence
	2.2.7 Switching Colours
	2.2.8 Repeat Orientation

	2.3 Visualization of Jacquard Designs on Fabric (View)
	2.3.1 Front/Rear Side View
	2.3.2 Grid & Graph View
	2.3.3 Front & Rear Visualization
	2.3.4   Front & Rear Cut
	2.3.5 Simulation

	2.4 Save Fabric Creations & Outputs (File)
	2.4.1 Save Fabric
	2.4.1.1 Public
	2.4.1.2 Protected
	2.4.1.3 Private
	2.4.2 Save As
	2.4.3 Printing
	2.4.3.1 Print Grid
	2.4.3.2 Print Graph
	2.4.3.3 Print Fabric Visualization
	2.4.3.4 Print Front & Back View of Fabric
	2.4.3.5 Print Front & Rear Cut of Fabric
	2.4.4 Exports
	2.4.4.1 Export as Grid
	2.4.4.2 Export as Graph
	2.4.4.3 Export as Texture
	2.4.4.4 Export as HTML
	2.4.4.5 Export as Text

	2.5 Design Punching & Calculations
	2.5.1 Manual or Piano Card Punching
	2.5.2 Automatic Card Punching (Utility)
	 Multi Page-Single Graph
	 Multi Page-Multi Graph
	The punching image generated from this option use for punching with multiple colors extra wefts (as colors in design). All the colors in design will be separately punch & different punch cards sequentially arrange after punching.

	2.5.2.2 Select Punching Machine
	2.5.2.3 Service Password
	2.5.3 Consumption Calculation
	2.5.4 Price Calculator

	2.6 Library of Fabrics (File)
	2.6.1 Search
	2.6.2 Sort
	 Sort by Date
	 Sort by Name



	3 Garment Layout
	3.1 Fabric Assignment
	3.2 Edit Fabric
	3.2.1 Jacquard Conversion
	3.2.2 Yarn Properties
	3.2.3 Thread Sequence
	3.2.4 Density
	3.2.5 Repeat Orientation
	3.2.6 Clear

	3.3 Garment Layouts Creation (Edit)
	3.3.1 Saree
	3.3.1.1 Pre-Defined Layout
	 Border across Body and Pallu
	 Single Cross Border
	 Border with Skirt border
	 Saree with Blouse

	3.3.1.2 Custom layout
	3.3.1.3 Repeat & Symmetry Setting

	3.4 Secure Garment Layout & Outputs (File)
	3.4.1 Print
	3.4.2 Export
	3.4.3 Save
	3.4.4 Open


	4 Dobby Weave
	4.1 Create Weave
	4.1.1 Design to Drafting
	4.1.2 Drafting to Design

	4.2 Edit
	4.2.1 Insert Warp
	4.2.2 Delete Warp
	4.2.3 Insert Weft
	4.2.4 Delete Weft
	4.2.5 Select
	4.2.6 Copy
	4.2.7 Paste
	4.2.8 Mirroring
	 Horizontal Mirror
	 Vertical Mirror

	4.2.9   Clear
	4.2.10 Move
	 One Move by 1

	4.2.11 Tilt
	 Right
	 Left
	 Up
	 Down

	4.2.12 Rotation
	 Clock Wise Rotation
	 Anti-Clockwise Rotation

	4.2.13 Inversion
	4.2.14 Double Layer Fabric
	4.2.15 Multi & Complex Weave
	4.2.16 Extra Warp (Dobby Patterns)

	4.3 View
	4.3.1 Zoom-In
	4.3.2 Zoom-Out
	4.3.3 Normal
	4.3.4 Tiled View
	4.3.5 Front & Rear side View
	4.3.6 Front & Rear Visualization
	4.3.7 Simulation View
	4.3.8 Colour ways
	4.3.9 Pattern Rendering
	4.3.9 Secure the Weave creations & Weave Library (File)
	4.4.1 Save/Save AS
	4.4.2 Open & Load Recent

	4.5 Import & Export
	4.6 Print (File)
	4.7 Entering into Fabric creator

	5 Artwork Designer
	5.1 Create size
	5.2 Sketch/Design Import
	5.3 Design Secure & Library
	5.3.1 Save/Save AS
	5.3.2 Open
	5.3.3 Load Recent

	5.4 Paint Application
	5.5 Import Refresh
	5.6 Edit
	5.6.1 Resize
	5.6.2 Reduce Colours
	5.6.3 Convert to Grey Scale/ Black & White
	5.6.4 Undo & Redo
	5.6.5 Colour Fill
	5.6.6 Artwork sketch
	5.6.7 Repeat orientation & Modes
	5.6.7.1 Horizontal Modes
	5.6.7.2 Vertical Mode
	5.6.8 Design Mirroring with Repeats
	 Horizontal Mirroring with Design Repeats
	 Vertical Mirroring with Design Repeats

	5.6.9 Jacquard Conversion
	5.6.10 Graph correction

	5.7 Jacquard Design Visualization (View)
	5.7.1 Front Side
	5.7.2 Front Visualization
	5.7.3 Front Cut
	5.7.4 Zoom Levels
	 Zoom-In
	 Zoom-Out
	 Normal

	5.7.5 Grid & Graph View
	5.7.6 Tilled View
	5.7.7 IKAT Effect

	5.8 Export & Print

	6 Configuration (Utility)
	6.1 Fabric/Artwork
	6.2 Warp Thread
	6.2.1 Thread Name
	6.2.2 Thread Colour
	6.2.3 Thread Count
	6.2.4 Thread Count Unit
	6.2.5 Thread Diameter Factor
	6.2.6 Thread Twist
	6.2.7 Twist Sense
	6.2.8 Thread Hairiness
	6.2.9 Thread Ply
	6.2.10 Thread Price (Per gram)
	6.2.11 Crimp

	6.3 Weft Thread
	6.3.1 Thread Name
	6.3.2 Thread Colour
	6.3.3 Thread Count
	6.3.4 Thread Count Unit
	6.3.5 Thread Diameter Factor
	6.3.6 Thread Twist
	6.3.7 Twist Sense
	6.3.8 Thread Hairiness
	6.3.9 Thread Ply
	6.3.10 Thread Price (Per gram)
	6.3.11 Crimp

	6.4 Miscellaneous Other Settings

	7 Support Modes
	7.1 Conversion
	7.1.1 Yarn Count
	7.1.2 Linear Measure
	7.1.3 Weight
	7.1.4 GSM Conversion

	7.2 Application Integration
	7.2.1 Application Name
	7.2.2 Application Type
	7.2.3 Application path

	7.3 Simulator
	7.4 Import/Export
	7.4.1 Data Export
	7.4.1.1 Fabric Data
	7.4.1.2 Artwork Data
	7.4.1.3 Weave Data
	7.4.1.4 Export
	7.4.1.5 Export & Delete

	7.4.2 Data Import
	7.5 Library
	7.5.1 Sorting
	7.5.2 Searching
	7.5.3 Update
	7.5.4 Change Permission
	7.5.5 Export
	7.5.6 Delete
	7.5.7 Export & Delete

	7.6 Translator
	7.6.1 Create
	7.6.2 Open
	7.6.3 Save
	7.6.4 Save As

	7.7 Help
	7.7.1 Help Guide
	7.7.2 Video Guide
	7.7.3 Support
	7.7.3.1 Technical Information
	7.7.3.2 About Software
	7.7.3.3 Contact Us
	7.7.3.4 Product Support
	7.7.3.5 Sign Out



